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Lab 1| Google Maps & Fusion tables

Most of you are probably already familiar with Google Maps, but probably less so with the experimental data visualization app, Fusion tables.  In this lab you will get experience learning the functionality of both applications and building a web-based map and a few other data visualization tools.  

Instructions.
Fusion tables stores your tabular data – just like excel or google spreadsheets – but in addition to storing & sharing that data, you can present your data in a visual and interactive way.  If your tabular data has any geographic information (lat/long, address, state name), it can also be mapped using Google maps.

Create google account. 
· PCC google accounts do not support Fusion Tables, so you will need to create a separate account with google.  If you already have a google account, then you can use it.

There are a few ways to get your data into a Fusion table – you can import data from an excel file, from a google spreadsheet, create a table from scratch, or you can import a table from public tables on the web.

Importing your data.
· Go into your Google drive and select new> google fusion table

· The first screen that appears is ‘Import New Table’.  Initially, we will search for public data tables to import into our fusion table.  In the search box, type in Food Stamps and click on the Search icon.
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· Scroll down to about the 5th or 6th result and you should see “Oregon counties mapped by food stamp usage” posted by the Oregonian.  Click on Export Data > Export to Fusion tables.  And finally, ‘Open the Fusion table’. 

· When the table opens, you will see that in additional to data related to food stamps, there is also data on poverty & unemployment for each county in Oregon.

Filtering data.
· Once the data is imported into Fusion tables, you can use a Filter to isolate or query certain data from the table.  We are going to look for counties where the percent of people of food stamps is greater than 25%.  

· First thing that we need to do is make sure that all our numeric columns are being recognized as numbers.  Hover over the column name, Pct on food stamps (last column in the table), all the way to the right and a small arrow will appear.  Click on it to get the drop down menu.  
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· You will see that it has ‘Sort A to Z’.  This is a clue that it is being recognized as text.  Go to ‘Change’ and under Type, change it to numeric and check ‘Validate data’.

· Click on ‘learn more’ next to the Validate data option.

1. What does it mean to have checked the ‘Validate data’ option?

· Go through and change all other numeric columns to Numeric (isn’t this so much easier than in ArcGIS???).

· Click on the Filter drop-down arrow and select Pct on food stamps
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· A window will appear that allows you to set the low & high value for your query.  It also informs you what the lowest & highest values are for that specific column of data (quite helpful).  Since we are looking for counties with 25% or higher on food stamps, enter the lowest value as 0.25 and the highest value as 0.35.

2. How many counties in Oregon have more than 25% of their population on food stamps?  Which county is the highest?  

· Close out of the filter and close the filter window.  Although we will want to use all counties for mapping purposes, you can imagine how you might have a dataset that includes all counties in the US and you can filter through and only select those in one state or with a certain value/range for one specific attribute. 

Creating a card. 
The Cards tab transforms the data in each row of your dataset into line-listed information on a single card.  This is just another way to view, sort & filter your data.  

· Click on the Cards tab and you will see the general format for the card.  By default, you will see all columns from the table in the Card.  Click on the drop-down menu on the Cards tab and click on “Change Card Layout”

· You have the option of automatically change the layout or customizing it using HTML.  Do an image search in Google for a food stamp (your choice!) and save/copy the url to the image.   You are going to add this image to the bottom of each card.  If you wanted to include a different image for each card, there would need to be a column in your table with the url to each image.

· While on Automatic, unclick the following columns: residents in poverty, poverty rate, unemployment rate. 

· Go to the Custom tab, and after the <br> for Pct on food stamps, add in the following HTML:  <b><img height="100" width="200" src="{imageURL}"></b>, replacing the {imageURL}, with the actual URL from your image.  Below is a screen shot to reference.  You might have to change the height & width for the image based on your specific image.
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· Click save.  When it returns to the main page you should see a preview of what the card will look like. 

3. Take a screenshot of your card and include it in your lab doc. 

Creating a chart or graph. 
The chart function summarizes data into a chart or graph.  There are 8 options for visualizing your data in this way: 3 for continuous variables, 3 for categorical variables, a pie chart, or a network graph.  

· Select the red + button right next to the Cards tab and go to ‘Add Chart’ from the drop down menu.  

· Take some time to play around with each of the various chart types, switching out variables, and any other parameters that exist for each specific chart type.

· Now – go back to the table for a moment and look at the values.  Notice that some of the have a % sign.  This is going to make all these data values appear as decimals (25% = .25).  For graphing purposes, this makes things look a little odd.  Take a minute to go through and edit the table so that all % signs are eliminated.  Go back to the chart tab when you are finished. 

· After some exploration, click on the Column Chart.  The Category should set to County as the default (if not, change it so that it is). 

· Under Values, check Poverty Rates & Pct on food stamps so that we can see the relationship between the two.  

· Go to ‘Maximum categories’ and change the number to 36 (the number of counties in Oregon).  

· Next, you will change the appearance of your chart by going to ‘Change Appearance’ in the upper right corner.  

· Customize your chart by giving it a title and changing fonts, legend, axis, colors, etc.  Make the chart look good!

· Add a second chart (go back to the red +) and make one of your choosing – select the style & variables and make sure to customize. 

4. Click Done when you are finished with your two charts, take a screen shot of each and add them into your lab doc. 

Creating the map with polygons (merging datasets).
And now – we map!  Since we are working with county data in the lab, we will start by mapping using polygons.  In order to display data on a polygon map you must first merge together the Oregon county data with a KML (Keyhole Markup Language) file.  Similar to a ‘join’ in ArcGIS, both files must have a common column with the same values (i.e. County name). 

· Go into File>New table and choose the OregonCounties.kml file that came in the Lab2data folder.  This will open up in a new table, but it is also being saved to your google account/drive.  

· Go back to your original table and there are two counties that have a * after the name (Sherman & Wheeler).  Go in and remove those by editing the fields.

· Now, we will Merge the tables so that we have the polygon geometry from the KML.  Go to File > Merge and select the OregonCounties KML that should appear in your list of tables. Click Next.

· Select the column ‘name’ under the OregonCounties file so that the two columns match and click Next.

· Keep all columns for the Merge and click Next. 

· This process creates a new table and when it opens, you will see that there is now a new tab across the top: Map of Geometry.  Click on that tab to view your County map of Oregon.

· Under ‘Feature Map’ go to ‘Change Feature Styles’ to change the appearance of the map to reflect one of the variables in the table.  This can be done under Polygons, Fill Color.  You can choose to go under Buckets or Gradient to select the column that you want to be reflected on the map.  

· Spend some time in here to do the following:

· Create a graduated color scheme for one of the quantitative valuables (make sure to click on ‘use this range’ in the fill color options)
· Customize the legend

· Next – click on ‘Change Info Window’.  This will look quite similar to the screen for the Cards we created in an earlier section.   The Info Window is what will appear when you click on one of the features on the map.  Customize this the same way we did with the cards (it doesn’t have to be the exact same as the card – just change the appearance to be easy to read and informative).

· When you are finished customizing your map – click Done.   Go to the drop down menu under the Map tab and click on publish.  You can see here that there is the option to copy to code and embed into a website or copy the HTML & Javascript to use with the Google Maps API.   Click on ‘Change Visibility’ and share with me at Christina.friedle@gmail.com.  

5. Insert the link to the map into your lab doc.  

Creating the map with points.
You can also make a map of points using Google Fusion tables.  One great aspect of this is that if you have a list of addresses, google will automatically geocode them for you with fusion tables.  There are a few different mapping elements that are available when mapping points that we will explore. 

· Go back to your google drive and create a new Fusion table. In the Lab2Data folder you will find a .csv file called PHC_lowIncomeHousing.  This is a list of low income housing units that one organization (PHC Northwest) in town manages.  It is not comprehensive of all low-income housing – just a sample to use for this assignment.  Browse to the .csv file, select it and click Next on the Import New Table window (the separator character is comma).

· The next window should show a preview of the table – click Next.

· On the last window – click Finish.

· Now that the table has been uploaded, we will need to assign the ‘location’ to our address column.  Hover over the address column until you see the drop-down arrow, click on it and go to ‘change’.

· Under Type, select Location.  Click Save.

· Right next to the Rows & Cards tabs, there is a red +.  Click on that and go to “Add Map”.  Once you do this, the addresses will automatically start geocoding.  And just like that – points are mapped.

· Click on Feature Styles and customize your map to show:

· Buckets based on the number of units, changing the colors to a graduated color scheme
· Add a legend

· When you are finished customizing your map – Click done.   Go to the drop down menu under the Map tab and click on publish.  You will create one more map (in the next section) and then share it with me.


Creating a heat map.
In addition to mapping out points, you can also create a heat map with Fusion tables.  

· Within this same Fusion table, add another map following the same steps as earlier.  

· Click on Heat Map and you will see that the visualization of the data changes from points to a ‘kernel density’ or heat map.  

· Using the Number of Units as the ‘weight’, create a heat map that accurately and clearly represents the data (changing the radius).


· When you are finished customizing your map – Click done.   Go to the drop down menu under the Map tab and click on publish.  You can see here that there is the option to copy to code and embed into a website or copy the HTML & Javascript to use with the Google Maps API.   Click on ‘Change Visibility’ and share with me at Christina.friedle@gmail.com. 

6. Insert the link to the map into your lab doc.  
 

Here are some links that you might find useful when working in Fusion tables  - just here for your own reference, nothing needs to be completed.

· https://www.youtube.com/watch?v=pRqAJwL6_3s 
· http://www.computerworld.com/article/2472247/enterprise-applications/how-to-make-a-map-in-google-fusion-tables.html
· http://www.smalldatajournalism.com/projects/one-offs/mapping-with-fusion-tables/
· https://datause.ucsf.edu/sites/datause.ucsf.edu/files/Google%20Fusion%20Tables%20User%20Manual_24%20March2015.pdf
· http://www.mulinblog.com/google-maps-tutorial-part-1-what-fusion-tables-is-and-does/
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