Lab 3 | Working with Spatial Data


Introduction
This lab will introduce you to a variety of geographic data models and types, and also give you a bit of practice in downloading GIS datasets from online websites.  Finding and gathering geographic data can sometimes be a difficult experience.  There are many different types of data and data formats.  Some data is already in a spatial format and can immediately be used in GIS programs, and other data you find may be in a format that requires a conversion or other process to be able to view it in a GIS.

Instructions 
Based on the assigned readings for this week, answer questions in Part I of this lab.  Then proceed to the next Parts and complete the hands-on exercises.  The data for this lab will be downloaded from various online websites.
 
Deliverables
Answer the following questions and produce the required outputs.  Your lab document should be typed, well organized, and submitted based on the “How To” guidelines provided in the course syllabus. 

PART I – Assigned Readings

Textbook – Bolstad (Chap. 7)
1. How does a Web Mapping Service (WMS) let you access data?
2. Why are global data sets less commonly available than national data sets?
3. What is OpenStreetMap?
4. Which government agency manages the production of each of the following types of datasets?  DLG, DRG, DEM, NHD, DOQ, NLCD, CDL, NWI, SSURGO, STATSGO, digital floodplain data, TIGER/Line.   

ESRI ArcGIS 10 Online Help Files
5. What happens when a raster dataset is georeferenced?
6. When georeferencing in ArcGIS, what does a Link Table show?


PART II – Working with Various Types of Geographic Data

Note: Zipped Files
GIS data are usually available in some sort of compressed (zipped) format. However, all zip formats are not readable by all compression/extraction software. Windows will open .zip files.  If you download a file that is in a different zipped format, you will need to use WinZip, 7zip, or another zip program.  7zip (http://www.7-zip.org) is an open source program and free to download.  

Shapefiles vs. Layer Files
“A .lyr file is directly readable only by ArcGIS software and other newer software applications. This file does not contain actual geographic data, but rather contains specifications for the presentation of other datasets. Such specifications include color shading, naming, label properties (font, color, placements, etc.). Such presentation properties are usually time-consuming to create, so a .lyr file allows these settings to be saved and shared. In order to use a .lyr file, you must also have a separate data shapefile with the same prefix name saved in the same filespace” (NCSU Library – GIS Data Services).

· In ArcCatalog, go to your Lab 3, Part 2 data folder and find cities.shp and cities.lyr.

1. In ArcCatalog, how can you tell the difference between the .shp and .lyr file?

2. What is the real difference between the two file types?

3. If you were to copy just cities.lyr (without cities.shp) onto your flash drive and try to open it in an .mxd document on a different computer, would it work (assuming ArcGIS was installed)?  Explain why or why not.


Feature Classes – Shapefiles and Geodatabases
“A Feature Class is a collection of geographic features with the same geometry type (such as point, line, or polygon), the same attributes, and the same spatial reference. Feature classes can be stored in geodatabases, shapefiles, coverages, or other data formats. Feature classes allow homogeneous features to be grouped into a single unit for data storage purposes. For example, highways, primary roads, and secondary roads can be grouped into a line feature class named ‘roads.’  In a geodatabase, feature classes can also store annotation and dimensions.” (ESRI GIS Dictionary – see http://support.esri.com/en/knowledgebase/Gisdictionary/).

Geospatial Data Clearinghouses: A “Clearinghouse” is a central location for collecting, maintaining, and distributing information.  It is a commonly-encountered term when looking for GIS data.   States often host a GIS data clearinghouse.

· Go the Oregon Geospatial Data Clearinghouse (OGDC) website: (http://www.oregon.gov/DAS/pages/irmd/geo/sdlibrary.aspx).
· Click on the link for “Spatial Data Library Alphalist”.
· In the “H” section, find the dataset named “Watershed Boundaries Dataset / Hydrologic Units”.
· In the “Download” column, click on the “File GDB” link to download the dataset for Watershed Boundaries and Hydrologic Units.  This is a large file (80 MB in size) and may take a few minutes to download.  Unzip the file.
· In ArcCatalog, preview the datasets in the unzipped geodatabase (WBD_OR.gdb).  Examine the metadata (hint: use the “Description” tab) for each dataset.

4. How many feature classes does this geodatabase contain, and what are their names?
5. What real-world features do the feature classes represent? (provide a general description)

· Choose two of the feature classes and add them to a blank .mxd in ArcMap.  In the Table of Contents, arrange the data layers so that the less detailed (general) feature class draws on top of the more detailed one so that both data layers are visible.
· Open the Symbol Selector window for the general feature class.  Change the Fill Color to “No Color” (so that you can see the more detailed features below), and increase the Outline Width to “3.00” to make the boundary line stand out better.

6. In Layout view, add a map title and your name, and export the map to a .jpg and insert into your Word doc.  


Coverages 
Coverages are an older data format from ESRI.  A Coverage is “a data model for storing geographic features. A coverage stores a set of thematically associated data considered to be a unit. It usually represents a single layer, such as soils, streams, roads, or land use. In a coverage, features are stored as both primary features (points, arcs, polygons) and secondary features (tics, links, annotation). Feature attributes are described and stored independently in feature attribute tables. Coverages cannot be edited in ArcGIS 8.3 and subsequent versions.”  (ESRI GIS Dictionary)

Since coverages store features in multiple file folders, they can be cumbersome to share.  To remedy this problem, ESRI created the ArcInfo interchange file format, which can be thought of as their version of a “zipped” file format.  Interchange files have the extension “.e00” (that’s the letter “e” followed by two zeros) and are often also called “Export files”.  Some websites make GIS datasets available only as Export files.  If you download an Export (.e00) file and unzip it, you still cannot view it directly in ArcMap; it must be converted to the Coverage format. 

· Go to the Regional Ecosystem Office website (http://reo.ordvac.com/maps/)
· Find and download the “Late Successional Old Growth, 1993” dataset (in .e00 zip format).  
· Save it your flash drive. 

Note: No spaces in your path name!!!  It is important that you do not have any spaces, dashes, periods or other symbols in your path name.  You can only use an underscore (_).  By default, if you save to the desktop, it will have spaces in the name, so...do not save to the desktop.  Instead, create a new folder for storing the downloaded data.

· Unzip the .e00 file.
· Convert to Coverage format.  In ArcMap, open the ArcToolbox window and choose Conversion Tools > To Coverage > Import from e00.  
· The input file is the .e00 File and the output dataset will be an ArcInfo coverage.
· Specify the output location (your flash drive) and give it an appropriate name – e.g. “late_forests”
· The coverage will now appear in ArcCatalog (you may have to refresh – you do this by right-clicking on the folder where you saved it and choosing “Refresh”, or pressing the F5 key on your keyboard).
· Add the dataset to a new empty map document (.mxd) and change the color to “Seville Orange” with no outline color.
· Save the map as “LateForests.mxd”.  In the next section you will add a basemap to this map.  


ArcGIS Basemap Layers
A Basemap is a group of data layers that draws continuously during navigation.  In ArcMap, Basemap layers provide a continuous visual context for data that you're viewing, editing, or analyzing.   
NOTE: Sometimes basemaps can be cumbersome and bulky, especially when redrawing frequently. If your basemap does not readily appear, turn the layer off and immediately back on to help the redraw process.

· Open your LateForests map and click on the “Add Data” button’s dropdown menu.  
· Select the “Add Basemap” option. 

[image: ]

· Within the “Add Basemap” window, select the “Topographic” option (Note: NOT “USA Topo Maps”) and click “Add”.
· Switch to Layout View and zoom in so that the old-growth late succession forest layer fills the page.  
· Take a few minutes to explore the variety of other basemaps offered through the “Add Data” options, including “Add Basemap” and “Add Data from ArcGIS Online”.

7. In Layout view, add your name and a title to the map, export to a .jpg and insert into your Word doc.


Digital elevation models (DEMs)
A digital elevation model (DEM) is a “raster grid of regularly-spaced elevation values, derived from the US Geological Survey topographic map series.”  (ESRI Help files)  DEMs are one of the most common digital data of the shape of the earth’s surface, and are typically used to represent terrain relief.  In order to use a DEM file in ArcMap, it must first be converted into ArcGIS Raster GRID format.

· Go to the Washington State Geospatial Data Archive (http://wagda.lib.washington.edu/data/) 
· Follow the link for Data by Geography > Washington State > Elevation Data. 
· Download a 30-meter DEM for the Puget Sound.  Click on the link for DEM of Western Washington including bathymetry.  
· Click on the link to the PSDEM2000
· You want to download the Raster format file.  Read through the information that describes the dataset and what you will be downloading.  Click on the link, ‘download psdem_2000.zip’
· Unzip the file.
· Convert to Raster GRID format.  Open the ArcToolbox window and choose Conversion Tools > To Raster > ASCII to Raster
· The input is the psdem file (psdem.txt).
· For the output raster, choose a filename (no spaces, dashes or symbols!) and save it to your falshdrive.
· In ArcMap, open a blank map and add the Raster GRID layer.
· Now, you are going to create a Hillshade view, which will give the raster more of a 3-D appearance.  You will use a tool from ArcMap’s Spatial Analyst extension.




Activating the Spatial Analyst extension
Spatial Analyst tools are part of the extension, Spatial Analyst.  In order for these tools to work, you must activate the extension.  In ArcMap go to Customize > Extensions, and check on the Spatial Analyst box.

· Open ArcToolbox and find Spatial Analyst Tools > Surface > Hillshade.  Double-click to open the “Hillshade” tool.  The input is the Raster GRID that you created, and the output will be the Hillshade – make sure it is saved to your flash drive.  

[image: ]

· Click OK and when it is done processing, add the new file to your map.  
· Move the GRID above the Hillshade layer, so it displays on top.  Right-click on the GRID layer name (in the Table of Contents) and select “Properties” to open the GRID properties window.  In the Display tab, change the transparency to 50%.  In the Symbology tab, change the color ramp to a more “real life” color scheme.

8. Change to Layout view and zoom in so that the GRID and Hillshade layers fill the page.  Add your name and a title, export as a .jpg and insert into your Word doc.

Note about the “Hillshades” tool:  This is a great tool for visualizing an area with dramatic terrain.  It is defined as the hypothetical illumination of a surface to create a 3-D effect that provides a sense of visual relief for cartography and a relative measure of incident light for analysis (A to Z GIS)








Finding your own GIS Data
Finding your own GIS data can be overwhelming, so you should get started with some experience sooner rather than later. 

· You’re on your own!  Go to one of the various locations for downloading GIS data and download at least 2 GIS datasets to create a map.

· In layout view, add a Graticule (see notes below on how to use ArcMap to do this i.e. Latitude/Longitude grid) to a map.  

· While in Layout view, add a title that describes your data, and add a text box of your data sources.  Add any other map elements you feel are necessary (north arrow, legend, etc.)

How to Add a Graticule (Latitude/Longitude Grid): Make sure you are in Layout view and then right-click the data frame and select “Properties”, then the “Grids” tab. Then follow the wizard to add the type of grid and level of detail you want.

9. What are GIS data formats did you download (i.e. shapefiles, DEM)?

10. What did you find most challenging about downloading GIS data?

11. In Layout view, keep the graticule on your map, export to a .jpg and insert into your Word doc.


PART III:  Georeferencing

Goal of this Exercise: To take a topographic map raster image (in .jpg format) and convert it to have real world coordinates.  In other words, you’ll take a plain scanned topographic map and make it into your own version of a Digital Raster Graphic (DRG)!

A DRG, or Digital Raster Graphic, is “A raster image of a scanned USGS standard series topographic map, usually including the original border information, referred to as the map collar, map surround, or marginalia.”  (GIS Data Dictionary)

If you have or receive a raster image that does not already contain spatial reference information, the image will not properly align with other data on a map.  In order to view and use the image with other geographic data, you need to georeference it – i.e. define its location using map coordinates and assign a coordinate system. 

In ArcMap you can find a “Georeferencing” toolbar, which will allow you to align a raster image (topo map of Sakhalin Island in the Russia Far East) with a river shapefile.  

To view the Georeferencing toolbar, go to Customize > Toolbars > Georeferencing.  
[image: ]

The Georeferencing toolbar will appear:
[image: ]


Download and unzip the Lab3data (if you have not already done so).  In the Part3 folder, you will find a topographic map raster file and a river shapefile.

Follow the steps below:

· Start a new, blank map in ArcMap. 

· Add layers to the map in the following order: rivers shapefile (SakhalinRivers) first, the topo map (KuraNaichaTopo) .jpg image second.

The two layers will not line up with each other because the topo map does not contain any spatial reference information.  Using the Georeferencing tools, you will change this.  Before you proceed any further, let’s find out the spatial reference system (or “projection”) of the rivers shapefile.

· In the Table of Contents, right-click on the SakhalinRivers layer and select the “Properties...” option.  This will open the Layer Properties window.

· Click on the “Source” tab.

Notice in the “Data Source” section that dataset is described as having a Projected Coordinate System of “WGS_1984_UTM_Zone_54N” and a Geographic Coordinate System of “GCS_WGS_1984”.  These two items comprise the spatial reference system of the rivers shapefile.

· Click the “Cancel” button to close the Layer Properties window.

· In the table of contents, right-click on SakhalinRivers and click “Zoom to Layer’”.

· From the Georeferencing toolbar, click the Layer drop-down arrow and choose “KuraNaichaTopo”.

· [image: ]Go to the Georeferencing drop down menu and click on “Fit to Display.”  This will display the raster image in the same general area as the rivers. 

· Using the “Shift”, “Rotate”, and “Scale” tools on the Georeferencing toolbar, move the topo image so that the rivers (in the image) line up with the rivers from the SakhalinRiver file (this will not be perfect, but you want them in the same general vicinity). 
[image: ]


· To line up the two river sets, you will need to find landmarks on the topo map and in the rivers shapefile and visually match them.  Use areas of the rivers that have defined features that can easily be picked out.   Make sure that you find the Nycha River on the Topo map to properly line it up with the shapefile – It is the only river system in the rivers file. 

HINT: Look at the eastern edge of the river system and find this unique shape; try to find a similar shape on the KuraNaicha Topo 
[image: ]
· Now let’s focus on adding Control Points, which allow you to link the landmark features in the SakhalinRiver shapefile with the same landmark features on the topo map image. 
[bookmark: _GoBack]
· In preparation for adding Control Points, you’ll need to deactivate the Snapping tool in ArcMap.  This is to allow you finer control over where your points are placed on the map.  (If snapping were active, your control points might automatically jump around to locations outside your area of interest.)

· Click on the Customize menu > Toolbars > Snapping.  This adds the Snapping toolbar to ArcMap. 
[image: snapping_toolbar]

· Click on the “Snapping” dropdown menu and turn off the “Use Snapping” setting.

[image: turnoffsnapping]

· Click the “Add Control Points” tool to add control points.  To add a link between the two data sets, click the mouse pointer on a known location on the Topo Map, then on the same known location on the georeferenced shapefile (it is important to add the points in that order to create a link!!!).
[image: ]

· With each control point you add, you will see the topo map image shift in one direction or another so that it starts to line up quite nicely with the SakhalinRivers features.

· When you are adding control points, be sure to evenly distribute them across the image - adding control points throughout the entire Naycha river basin.

· Add enough links for an accurate transformation of the Topo Map (somewhere around 20 links).  You can check or delete your links by clicking View Link Table (the icon furthest to the right on the georeferencing toolbar).  

· When you’re satisfied with the alignment between the two datasets, stop adding control points.

· [image: ]Go to the Georeferencing drop down menu and “Update Georeferencing” to save your work.


· The “Update Georeference” tool creates a new file with the same name as the raster image but with an .aux.xml file extension.  It also creates a world file for some of the file formats, including .tif and .img files.  These files store the spatial information associated with the image.

· You have now transformed a regular image into a georeferenced image for use in a GIS system.  If you add the topo map to any .mxd, with additional layers from Sakhalin Island, they will all line up properly.

12. When you brought the topo map into ArcMap, it did not have a spatial reference (projection) and now it does. What spatial reference system does the topo map now have?

13. How can you determine the spatial reference system for the topo map?

14. Why is it in this particular spatial reference system?

15. In Layout view, add your name, export the map and insert into your lab document.****  Be sure that the rivers layer is displayed over the Topo Map in a color that is visible (I need to be able to see your work).  
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