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Introduction
This will introduce you to querying, linking attribute data, and creating spatial data from tables in ArcGIS.  You will learn the following: attribute queries, location (spatial) queries, definition query, joining tables, relating tables, and spatial joins, and adding x/y data. 

Instructions 
Based on the assigned readings for this week, answer questions in Part I of this lab.  Then proceed to the next Parts and complete the hands-on exercises.  Before working with the lab data, copy it from the course website onto your flash drive.

Deliverables
Answer the following questions and produce the required outputs.  Your lab document should be typed, well organized, and submitted based on the “How To” guidelines provided in the course syllabus.

PART I – Assigned Readings

Textbook – Bolstad (Chap. 8, pgs. 307-315, 321-331)
1. What is a database management system (DBMS)?
2. List three advantages of using a DBMS instead of a “flat file” spreadsheet.
3. Give a brief definition of each of the following database terms:
a. Record
b. Attribute
c. Domain
4. What purpose do “keys” serve in a relational database?
5. What is a query?
6. Provide an example for each of the following query type:
a. Simple selection
b. AND selection
c. OR selection
d. NOT selection
7. What are three ways to verify that a selection has worked as expected?
8. What query language is often supported by relational databases?
9. In the context of joining tables, what is a “one-to-one” relationship?
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10. When adding a table of x,y coordinates to your map, what must you do if the coordinate values are stored in Degrees-Minutes-Seconds (DMS) format?
11. What is a definition query, and where do you access it in ArcMap?
12. What are the two main ways to select features interactively on a map?
13. When selecting by location, what does the “Are within a distance of” operator create?
14. The “Select By Attributes” tool allows you to select features using what? 
15. What tool do you use to export selected records as a new dataset?
16. What is the general form for query expressions in ArcGIS?
17. Why do you join or relate tables?
18. What is the main difference between a join and relate?
19. When looking at appended fields in a joined table, how do you know which table each field originally came from?
20. List four reasons why joining tables may fail.
21. How is a spatial join like a table join, and how is it different?
22. Is a spatial join temporary or permanent?

PART II: Creating GIS data from Coordinate Data 

Add XY Data – There are times when you find data that is in a non-spatial (table) format, but still contains spatial information (e.g. latitude & longitude coordinate points).  In ArcMap, you can turn spatial information from a table into points on a map.

· You will make a map to show the migration path of the endangered Whooping Crane bird species in North America.  Even though you don’t have a shapefile of the migration path, you do have an Excel table listing the latitude and longitude coordinates for the points where Whooping Cranes have been known to stop along their migration path.

· In Microsoft Excel, open the WhoopingCrane.xls file (found in the Lab 6, Part 2 folder).  Examine the file to find the place names, as well as the latitude and longitude coordinates, of the migration path stopping points.  Close the Excel file.

· In ArcMap, open a new blank .mxd.  Add the states shapefile (from the Lab 6, Part 2 folder) and the Migration worksheet (from WhoopingCrane.xls) to the map, and save as WhoopingCraneMigration.mxd.

·  Go to File > Add Data > Add XY Data
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· The “Add XY Data” window will open, and should automatically recognize the Migration worksheet.  Make sure that the X Field is set to “Longitude”, and the Y Field is set to “Latitude”.  

· The “Coordinate System of Input Coordinates” should automatically be set NAD83 (Name: GCS_North_American_1983).  If not, click on the “Edit” button to set the Projection and navigate to the Geographic Coordinate System, NAD83.  Click OK to continue.

1. Why is NAD 1983 an appropriate projection to use?
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· If you get a warning window (shown below), click ok – it is just letting you know that is not a permanent data set, nor is it a feature class.  In order to have the functionality of a spatial data set, it needs to be exported.  
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· The Latitude/Longitude points will appear on your map as a new layer called “Migration Events”.  Note that this data is a temporary dataset and exists spatially only within this map document. 

· Convert the “Migration Events” layer into a permanent shapefile by exporting the layer. Right-click on the layer name and go to Data > Export data.  Name the new shapefile “MigrationPoints”, click OK and add to your map.

Creating New Shapefiles:
Sometimes you want to create a new shapefile from a subset of features in an existing feature class (shapefile, coverage or geodatabase).  To create a new shapefile, right-click on the layer name and scroll down to Data > Export Data.  You have options to choose all features, selected features, or the features that are in the viewing window to include in your new shapefile.  There are also options for which coordinate systems to choose for the new shapefile: the original layers source or the data frame.
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· Switch to Layout view and create a map of the Whooping Crane migration path.  

· Choose an appropriate map projection and scale.
· Change the symbology for the Migration Points features.
· Mark the Whooping Crane migration path by drawing a line that connects all the points, using the Draw toolbar > Curve tool.  (Note: if you change the map scale after this step, you’ll need to re-draw the migration path.)
· Include a title, the data source (www.operationmigration.org), your name, and any other layout elements that you feel are necessary to enhance the map cartography.

2. Export your map as a JPEG and insert into your lab document.


PART III:  Querying Spatial Data
Section A.  Interpreting Earthquake Data

You will analyze earthquake data from the United States during the last 400 or so years. 

· Open ArcMap and create a new blank .mxd (map document).  

· From the Lab 6, Part 3 folder, add the “Significant US Earthquakes 1568-2004.lyr” layer file and the “States.shp” shapefile to your blank map.  If the data link in the layer file is broken, use the “Repair Data Source…” tool to connect it to the “quakehis.shp” shapefile.

· Zoom in to the continental United States. 

· Open the attribute table for the Significant US Earthquakes layer.  If needed, click and drag on the field division lines to make more table fields visible (or make the table window size larger by clicking and dragging on one of the table window corners). 

· Looking at the attribute table, there are many earthquakes that have a reported magnitude of -9999.00 (which means no magnitude data is available for that earthquake event), as listed in the “MAG” field.  Also, the “LOCATION” field shows that there are many earthquakes recorded in areas outside of the continental United States.

· We’ll make the data set easier to work with by eliminating data we don’t need.  First, we’ll use one type of selection tool to include only those events that have a magnitude value recorded for them (i.e. a magnitude greater than -9999.00).  Next, we’ll select earthquakes within the continental United States using another selection tool type.

Select by Attribute - This tool is an attribute query, and is similar to a “Search” technique used in Excel or any other database program.   It allows us to request data (i.e. select features or records) from an attribute table.  You can access this tool in one of two ways (note that you only need to use one tool to create a selection)…

1) “Selection” Menu > “Select by Attributes…” option:
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2) OR  Open Attribute Table > “Table Options” button (on the top menu bar) > “Select by Attributes…” option:
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· Open the “Select by Attributes” tool (using either method) for the Significant US Earthquakes layer.

· You want to include only those events that have a magnitude value recorded for them (i.e. a magnitude greater than -9999.00).  There are more than one ways to do this, but try this method: double-click the magnitude attribute field “MAG”, then single-click the greater than button “>”, and then type in the number zero (0 with no quotes).

· To check that the program recognizes your typed entry, click “Verify”.  If the response is affirmative, click “Apply”.  All selected features should be highlighted in blue.

3. How many records with a magnitude greater than -9999.00 have been selected? 

· Now, create a temporary new layer with this data (read below).  By default, this new layer will be named “Significant US Earthquakes 1568-2004 selection”.


Creating New Layers: You can create either a temporary or permanent new layer file to display on your map.

To temporarily create a layer file:  right-click on the selected layer name and scroll down to Selection > Create Layer From Selected Features.  (Using this method means that if your data links are broken, so will this selection.)

To permanently create a layer file:  right-click on the selected layer name and scroll down to Data > Export Data. 

· When the new layer is added to the map, clear the selection using the “Clear Selected Features” tool.  In addition, “shut off” (i.e. un-check) the original layer (Significant US Earthquakes 1568-2004) in the table of contents.

· The symbology for your newly-created layer makes it difficult to see the patterns of earthquake magnitude.  Go into the Layer Properties Symbology tab and import the symbology from the Significant US Earthquakes layer using the MAG (magnitude) field.
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· Now, let’s get familiar with using the second type of selection tool – “Select By Location”.

Select by Location – This is a spatial query method that allows you to select features of a layer based on their location and/or spatial relationship to other features.  You can ask questions that involve such relationships as proximity, adjacency, and containment.  

· Using the “Interactive Selection” tool (on the Tools toolbar), select the state of California. This is in preparation for using the “Select By Location” tool.
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· Open the “Select By Location” tool.  You want to further refine the selection originally created with the Select By Attributes tool, by targeting those earthquakes that occurred within California (i.e. intersect with the California State boundary polygon).  So within the Select By Location tool, “select features from” the “Significant US Earthquakes 1568-2004 selection” layer, where the earthquake features intersect with California (a selected feature within the “States” Source layer).  
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· Open the “Significant US Earthquakes 1568-2004 selection” attribute table, and display only the selected features (click the “Show selected records” button). 

4. How many Earthquakes occurred in California between 1568-2004?

5. In terms of Richter magnitude (the “MAG” column), when and where was the strongest earthquake to hit California?  (Hint: Sort Descending) 

· Close the attribute table and clear your selection (“Clear Selected Features”).

· Now, we want to look at severe earthquakes that have occurred in the last century.  We will use a definition query to eliminate all other features so we can explore only the most recent and more severe earthquakes. 

Definition Query – This tool is very similar to Select By Attributes - essentially you are conducting a search within the attribute table for your data layer of interest.  Sometimes, you do not want to query an entire dataset, or you want to temporarily remove some of the features in the data layer.  You can instead temporarily remove unwanted features using a Definition Query.  To access this tool, go to Layer Properties > Definition Query

· Open the Layer Properties window for the “Significant US Earthquakes 1568-2004 selection” layer, and click on the “Definition Query” tab.  Click on the “Query Builder” button to open the Query Builder window.  
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· Within the Query Builder window, in the “SELECT * FROM quakehis WHERE:” section, enter a query to find all the earthquakes that occurred after 1900 AND have a magnitude greater than 5.0.
	
Query Logic – Queries are based on logic.  You will notice a bunch of buttons like “OR”, “NOT” and “AND”. What you want to do is find all the earthquakes after 1900, as well as the ones with a magnitude greater than 5.0. This would be an AND statement.  In other words, you’re telling ArcMap: 

“I want you to search the attribute table for all the earthquakes that have BOTH of the following properties: a date of occurrence ‘greater than’ 1900 AND a magnitude ‘greater than’ 5.0.”

If you were using the OR statement with the same criteria, you’d be telling the program:

“I want you to search the database for all the earthquakes that have EITHER (or BOTH) of the following properties: a date of occurrence ‘greater than’ 1900, OR a magnitude ‘greater than’ 5.0. “

Important Query Tips – There are a lot of intricacies of writing a query using SQL.  You can click on the “Help” button in the Query Builder window – this will provide general instructions for writing SQL query logic.

· After entering your query, click “Verify” to make sure that the query you wrote meets SQL guidelines.  If verified, then click OK to close the Query Builder window, then OK again to apply the Definition Query and close the Layer Properties window.

6. What query did you write?

7. How many earthquakes are displayed after you applied your definition query? (Hint: look in the attribute table)

8. Where did the strongest earthquake occur in the year 2002, and what was its Richter magnitude value?

· Save your map document as “Earthquakes.mxd” (you will need to use this map again) and close.



PART III:  Querying Spatial Data (continued)
Section B.  Writing SQL Queries

Open a new blank .mxd document and add EuropeDemog.shp from the Lab 6, Part 3 folder.  This data layer lists demographic information for regions (provinces) throughout Europe.  Using the Select by Attribute tool, write a SQL query to answer the following questions.  Use your text and the ESRI Help function as a reference for query logic.

Include the query you wrote, as well as the answer to the question.

9. How many regions (provinces) have a population of at least 100,000 people (i.e. 100,000 people or more)?  What query did you use?

10. Of those regions (from Question #9), how many regions have at least 50,000 men?  What query did you use?

11. How many regions are majority male?  What query did you use?

12. You need to find all the regions that start with the letter “M”.  How many are there?  What query did you use?

13. How many regions are in Spain (España) or Portugal? (Hint: use attribute field “NUTS0” which lists “Nomenclature of Territorial Units for Statistics, Level 0” codes.)  What query did you use?

14. How many total regions have a growing population?  What query did you use?


PART IV: Table Joins & Relates, Spatial Joins
A. Table Join

Table Join – A table join appends the attribute fields of a non-spatial table to a (spatial) layer attribute table, creating one large table.  Joins are used when there is a one-to-one table relationship – i.e. for each geographic feature in the layer there is one match in the non-spatial table.  (Joins are also used for many-to-one table relationships.)

· You have been asked to create a map of the numbers of Refugees from countries around the world, as part of an effort to understand from which countries refugees are emigrating.  Open a new .mxd and save it as InternationalRefugees.  From the Lab 6, Part 4 folder, add the “Countries” shapefile to the map.

· Open the attribute table for the Countries shapefile, and explore.

15. What information do you find in the attribute table?

· Since there is no data about refugees in the existing Countries shapefile, you need to get the data from an alternative source.  In the Lab 6, Part 4 folder you will find an Excel (non-spatial) table called “InternationalRefugees.xls”.  Add the “Refugees” worksheet within the Excel file to the map.  (Note that you cannot add the entire Excel file, you must go in and select a specific worksheet to be added to your map). 

· In order to see the non-spatial table on the map document, you have to switch to the “List by Source” tab on the Table of Contents.  

· Join the non-spatial table to the Countries shapefile by right-clicking on the Countries layer name and going to Join and Relates > Join.
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· The “Join Data” window displays.  You want to make sure that you are joining the tables on the common field – the country name.  In the Countries table this field is called “CNTRY_NAME”, while in the Refugees table it is “NAME”.

Note:  It is ok that the common field has a different header name in each table (CNTRY_NAME and NAME).  HOWEVER, the actual country names in both tables must match up identically.  For example, the Democratic Republic of Congo is listed as “Congo, DRC” in both the Countries and Refugees table.  If it were not in this exact format in both tables, you’d need to edit the attributes in one table or the other.
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· Join your tables based on the country names, using the screenshot above as your guide.  You can make sure that your Join will work by clicking on the “Validate Join” button.

· Open the Countries attribute table again, and scroll to the far right to see the newly-added fields from the Refugees table.

16. What country has the largest number of Refugees?

· Make a map, using the Quantile classification method and five classes, of the number of Refugees from each country.  Include a title, legend, your name, and choose a map projection.  (Hint: In order to show all the countries with “No Data”, add a copy of the countries shapefile to the map – as a base layer – and make a solid color.)  

17. Save and export your final map as a JPEG, and insert into your lab document.


PART IV: Table Joins & Relates, Spatial Joins (continued)	
B. Table Relates

Table Relate – A Table Relate keeps the spatial and non-spatial tables separate but linked.  This means that if you select records in one table, records in the related table will also be selected.  Relates are used when there is a one-to-many (or many-to-many) relationship between attribute tables.

· Although this tool is available in ArcGIS, database applications (such as Microsoft Access) are much more sophisticated in handling table relates.  We will only go over one function of the Relate tool – exploring data.

· Open a blank .mxd document, add the States shapefile from the Lab 6, Part 4 folder, and save the map as US_Senators.  Open the States attribute table and explore its data.

18. What information is available in the States attribute table?

· Add the US_Senators.xls Excel file, “Senators” worksheet, to the map.

· Right-click on the States layer and go to Joins and Relates > Relate.
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· The “Relate” window will display and walk you through the inputs to relate the two tables.  You will relate the “STATE_NAME” field from States shapefile, with the “STATE” field from the Senators table.

· Name the Relate “Senators” and click OK.

[image: ]

· Now using the Identify tool, click on Ohio.  The Identify window will appear.  At the top of the Identify window, expand the list under Ohio by clicking on the plus “+” sign next to it.  You see that the relate (Senators) is listed.  Expand the list under Senators, and now you see the data from the related table that is associated with Ohio – the names of the two senators from that state.  Click on the name of each senator (Rob Portman and Sherrod Brown) to view additional attributes – e.g. CLASS and PARTY.
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· Continue using the Identify tool to answer the following questions:

19. Who are the two Senators from Hawaii?

20. Which western state has one republican and one democratic senator?

· Note: You can also create, remove, and manage your table joins and relates through the Joins & Relates tab in a layer’s properties (see image below).  
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PART IV:  Table Joins & Relates, Spatial Joins (continued)
C. Spatial Join 

Spatial Join – A Spatial Join allows you to join attribute tables from two separate datasets, based on the spatial relationships among the features within each dataset.  This tool provides options for joining layers based on a variety of spatial relationships.

· Open your Earthquakes.mxd map from earlier in the lab.  

You will make a classified map of the number of Earthquakes per state.  In order to map this information, you need to know how many earthquakes occurred in each state.  Look through both attribute tables.  

21. Is there any attribute field in either table that allows you to map such data?  If so, which field?

· Before we continue, go into Layer Properties for the “Significant US Earthquakes 1658-2004 selection” layer, and change the Definition Query to include only Earthquakes with a magnitude greater than zero.

· For your Earthquake map, you need a sum count of all earthquakes in each state.  You can use the Spatial Join tool to complete this task.  Right-click on the States layer and navigate to Joins & Relates > Joins.

· The first question in the Join Data window is “What do you want to join to this layer?”  From the drop-down menu next to this question, select “Join data from another layer based on spatial location”.  This indicates that you’d like to do a Spatial Join (rather than a Table Join).

· For the “layer to join to this layer”, choose the “Significant US Earthquakes 1568-2004 selection” layer.  

· The Join Data window allows summarizing the numeric attributes of the points that fall inside the States polygons, according to different statistical measure.  Be sure to click the checkbox for “Average”.

· A Spatial Join creates a new output shapefile – call it “StatesQuake.shp”.  Note that the output shapefile includes all of the attribute fields from both of the input layers, plus any calculated statistical fields.  In addition, the output shapefile includes a “Count” field that represent the number of points that fall within each States polygon.

· Confirm your settings in the different sections of the Join Data window, as highlighted in the screenshot below.
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· Click OK and add the new shapefile to your map document.

· Open the attribute table and scroll to the end of the table.  You should see the fields: Count and avg_x, where x represents each numerical field from the Earthquakes.  

22. What does the field “Avg_MAG” represent?

23. What do the fields “Avg_MONTH”, “Avg_DAY”, “Avg_HOUR”, “Avg_MINUTE”, and “Avg_SECOND” represent?  Are they meaningful?  Explain.  

24. What field will you use to make a map of the number of Earthquakes per state?

· Make a classified map of the Number of Earthquakes, by state.

25. Add a title, legend, your name, and choose an appropriate projection.  Export the map as a JPEG and insert into your lab document.
Part V:  Adding a Text Table, Joining to a Shapefile 
This project introduces something quite common, which is joining ASCII tabular data with a shapefile. Here you will combine a text file on corn production (per county) with a county shapefile.  Note that there are many types of tabular data that are available as text files, such as population, voting, education, income, crime, air pollution, etc.

You will import a text file, convert it to an ArcMap compatible table, and edit the table, deleting columns, creating join items, and combining rows before joining it with a polygon shape file. These are all common operations when working with tabular data.

· Start ArcMap, and add lwr48.shp from the Lab 6, Part 5 folder. 

· Add the text file cnty26.csv to this data view, and open the table for viewing.

This file contains 1996 seed corn production, in bushels, for counties in the United States.  These data were downloaded from the National Agricultural Statistical Service website, www.nass.usda.gov/, and we’re most interested in the columns:

· Stfips:  the state Federal Information Processing System (FIPS) code,
· CoFips: county FIPS code,
· Harvested: the acres harvested for a given yield category in a county,
· Yield: Bushels per acre harvested for the yield category, 
· Production: Total bushels produced (yield times harvested) for the given yield level.
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Unfortunately, we can’t directly edit the .csv file, so we must convert it to a dbf file (also called dBase table).

· In the Attributes of cnty26.csv window, select the “Table Options” dropdown in the upper left portion of the table window frame, and then “Export” in the dropdown menu, and save all records to the Part5 folder, naming it something like “raw_corn_dat”. Data will be added as a dBase table to your map. To check and be sure, check in the new table properties under the Source tab. 

· Remove the cnty26.csv from the data frame, in order to reduce clutter.

· Open the raw_corn_dat attribute table.

Now you’ll delete all the columns except the following: OID, Stfips, CoFips, Harvested, Yield, and Production.

· Delete columns by right clicking in the column heading, and selecting Delete near the bottom of the dropdown menu. 

We now want to join this data with the county shapefile, lwr48.shp.  Unfortunately, there are two problems.  First, we don’t have a ready-made key for the join.  There is no column that maps cleanly from the raw_corn_dat.dbf file to the lwr48.dbf file.  Let’s first fix this problem.

· Open the data table for the lwr48 shapefile.

Notice that lwr48.shp also has the county and state FIPS codes, in the COUNTY and STATE columns, respectively.  Each state has a unique FIPS code, and each county within a STATE has a unique code.  If we combine the STATE-COUNTY codes, we can create a unique ID for each county across the United States.


· Add a new field to the lwr48 data table (Table Options > Add Field in the lwr48 Table window).  Make this field a long integer, with at least 8 columns (precision), and name it something like “sta_count”.

· Use the field calculator to assign sta_count a value according to the formula:

 [STATE] * 10000 + [COUNTY] 


Multiplying the STATE by 10000 and adding to COUNTY creates a unique 5-digit code, with the value for STATE in the first two digits, and the value for COUNTY in the next three digits.

· Open the raw_corn_dat.dbf file, add a sta_count column similar to the one in lwr48.

· Using the Field Calculator, add values to the new column according to the formula:

[Stfips] *10000 + [CoFips]


· Now, sort the raw_corn_dat table in ascending order. (Hint: right-click on the sta_count field name.)
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You should have a window that looks something like the figure to the right:

We can now see the second problem with this data set. 

Note that there are multiple entries for sta_count, for each state/county combination.  This is because yield was reported at various levels for each county.  

We must aggregate the rows before we join this table to the lwr48 shapefile. A join matches the rows by a key. If we don’t somehow summarize the multiple rows that have the same sta_count value, then we can’t be sure which will be chosen for the join (because many-to-one joins are ambiguous).  Fortunately, ArcMap provides a tool for aggregating rows. 
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· Right click on the “sta_count” column heading in the raw_corn_dat.dbf table.

· Left click on the “Summarize” option in the dropdown menu.  This will open the Summarize window. 

· In the Summarize window, Section 1, verify that the “Select a field to summarize” section is set to the sta_count field.

· [image: ]In Section 2, you see a list of available items. Left clicking on the +/- to the left of each item displays a list of summary statistics you may request.

· Request the “Sum” summary statistic for the “Harvested” and “Production” variables.

· Specify your preferred output location, with a filename something like “Sum_crops.dbf”. Make sure the “save as type” is .dbf, if asked.

· Click OK, and when asked, add the data to the map view.

· Remove the raw_corn_dat.dbf from the data frame.

· Open the output Sum_crops file, sort ascending by sta_count, and verify that sta_count with a value of 10001 has a Sum_Harvested of 5700, and a Sum_Production of 317000.

· Now, join the summary table you just created to the lwr48.shp file (Right click on lwr48.shp in TOC > joins and relates > Join, than select appropriate columns in the shapefile and the summary table).  Answer “Yes” to the request to index the results.
We want to further process this combined data. Because many operations are restricted on joined files, it is best to save a copy to a new file.

· Right click on the lw48.shp in the TOC, then left click Data > Export Data, and name and save the file appropriately, something like US_corn.shp

· Add this new file to your data frame, and remove the lwr48 file and summary production tables.

Now, prepare your data for output. First, change the data frame projection to something more appropriate for viewing, e.g. Albers Equal Area Conic (USA Contiguous).

· In the Table of Contents, right click on the data frame name, click on the “Coordinate System” tab, then select Predefined > Projected Coordinate Systems > Continental > North America > USA Contiguous Albers Equal Area Conic. 

· Symbolize the US_corn.shp file using the Quantities > Graduated colors option. Set the Value option to “Sum_Harvest”, and choose a gradient color ramp between two distinct colors (e.g. from red to green).  Classify using Natural Breaks with 10 classes.  Right click on the first range, select “Properties for all Symbols”, then “NO COLOR” for the Outline Color.  Select Ok to apply the changes.

· Refine the display of the labels of the Quanties of Sum_Harvest by again by right clicking on the first range then selecting Format Labels, see right.  Select Ok, Apply and OK to complete the changes to your Symbology.

· Add states.shp to the map view, and symbolize using no Fill Color and a dark outline color.  Create an appropriately annotated layout, with title, north arrow, name, legend, and other descriptive elements.  An example layout is shown below.

26. Export the map as a JPEG and insert into your lab document.
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PART VI: Create your own Thematic Map

Create a Thematic Map using Non-Spatial Data 

To create a thematic map, you will find non-spatial data to join to either the Countries or States shapefiles (used in the other parts of this lab).

***Note:  If you plan to use joined data as part of your Final Project, you can use this part of the lab to create a first draft of your Final Project map.  E.g. find a table that can be used in your final project (if this is the case, you do not have to use the States or Countries shapefile as described below).***

· Go to www.nationmaster.com or www.statemaster.com.  Both of these websites provide a large range of statistics on a variety of themes including agriculture, economy, lifestyle, media, terrorism, among many others.  NationMaster provides stats on nations throughout the world, while StateMaster goes into finer detail for the states of the US.  Follow the “Statistics” link on either website to find a topic of interest.

· Create an Excel table from the stats.  (Tip: Copy text and numerical data directly from the website page, then paste into Notepad or other text editor to strip out any unusual formatting.  Then copy and paste directly into an Excel worksheet.)

· In your Excel table, make sure that:
· Columns are formatted appropriately (see Lecture – Joins & Relates).
· A common field exists in both your Excel file and shapefile. (e.g. Country Name)

· Join the Excel table to an appropriate shapefile (e.g. Countries or States).  

· Make a map that represents that data with a title, legend, your name, and any other map elements that are necessary to communicate your information.

27. Export your map as a JPEG and insert into your lab document.
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