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[bookmark: _GoBack]Lab 2. Exploring Google Maps & Earth
Google My Maps let you quickly and easily make custom maps and share them with others.  This tools allows you to:
· Draw and style points, line & polygons
· Manage your maps in Google Drive
· Edit your maps
· Import data from Google sheets, .csv, excel, or KML 
· Embed maps into a website

Google Earth allows you to see 3D terrain features, create flyover tours, and add your own content.  It is a client-side application, which must be installed on your computer, as opposed to Google Maps, which only requires a browser.  If you don’t already have Google Earth on your computer, you can download & install it now.  Google has now made Google Earth Pro available at no cost – use your email address and the Key: GEPFREE to login.

http://www.google.com/earth/download/gep/agree.html 

Instructions.
Following the instructions below, you will import data, create a map, and explore the functionality of Google Maps & Earth.  Answer any questions in bold.

Google Account.
You will need to use your Google (non-PCC) account to create a Google Map.  

Part I | Google Maps.
· Log into your Google Account and go to Google My Maps (https://www.google.com/mymaps).  

· On the Welcome page, click on Create a New Map.

· In the upper left-hand side of the screen, click the text Untitled Map to edit the map title and description.  You are going to be mapping Bike Crash data from the Portland Metro area is 2014.  Give your map the title, ‘Bike Accidents, 2014’ or something similar to that.  You will come back later in the lab to write the Map Description.

· Open up the PDX_BikeCrash.csv in excel and take a few minutes to look through the data.  You can also use the documentation provided (in Lab2data folder) to help understand some of the column titles for the attributes.   The table includes data on location (county, city, urban area), roads (classification, speed, name, type), and the crash itself (type of injury, hit & run, drug or alcohol involvement, etc).

Importing data.
· First, we will import this .csv file into the Map.  In the menu, select Import.
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· Select the PDX_BikeCrash.csv from the Lab2data folder.

· After uploading the data, it will ask you to select which columns have location information so that you data can be correctly placed on the map.  In this case, you have the lat/long coordinates.  Check the Lat_DD (latitude) and LongTD_DD (longitude) and click Continue.
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· Now you can pick the column you’d like to use to title your markers.  Check Crash_SVRTY_LONG_DSC and click Finish.

· You should now see your data as a layer in the menu and your points plotted on the map.  If you would like to change the name of this layer in the menu, you can select the text of the layer name and change it.  By default, the layer name will be the file name.

· Now, let’s upload a second data layer.  Click Add Layer.
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· Go through the same steps to import the MetroCities.kml.  When you are finished you should see both layers appear in the menu and on your map.

· Although we won’t be using this option – you can also add data to your map by manually creating point, lines or polygons from the menu.  
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· You can either create a new Layer (Add Layer) to do this or highlight a layer in the menu to add features to an existing layer.  

· One more feature to highlight – Add Directions (the arrow in the menu above).  You can add a layer to your map that shows directions from two (or more) points.  Give it a try!

Stylizing your data.

· Let’s start by changing the Base Map.  The Base Map colors/style will influence how you want to represent the  other data layers.  Scroll down the Map menu and click on the drop-down menu next to Base Map.  Your options for base map styles will appear.  Select a style of your choice.
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· Next, let’s customize the Cities data, which is currently represented as Individual Styles.  Go to the Cities layer in the menu.  Click on Individual Styles and change it to a Uniform Style (no labels).  Then, hover your cursor over All items (53) and a paint can icon will appear on the right.  Click on the paint can.

· Selecting the paint can will pull up a menu of choices for colors, transparency, and Broder width.  Customize each of those options so that it works well with your Base Map style.

· Now – the Bike Crash data.  There are a few ways that we can symbolize this data since it has a number of attributes in the table.  Hover your cursor over All items (540) and click on the paint can when it appears.  It pulls up a menu of choices for colors and shapes.  If you select More Icons, even a larger selection will appear.  At the bottom of that screen you will also see an option for ‘Custom Icon’, which allows you to upload an icon or search Google Images to find one.  Choose an icon & color that you find work wells for representing the data.

· Next, add the Bike Crash .csv again (repeat steps from earlier), so we have two layers on the map and can symbolize each one differently.   Once the new layer is added, click on Uniform Style (and you might want to shut off the first bike crash data layer to make it easier to see) and let’s Style by Data Column.  I will let you choose which data column to represent, but will walk you through one example.

· Under the Style by Data Column, click on ALCHL_INVLV_FLG column (this is showing which bike crashes involved alcohol, 1=yes, 0=no).  Use the Categories option.

[image: ]

· Close the menu and then you can individually select colors for each category.  

· Explore the options here – if you choose a column that is numeric and has a large range of values, you can use the ‘Ranges’ option to classify the data into groups.  If you want to look at the data table, go to the Layer Options and Open Data Table.
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· Customize this data layer to represent one attribute from the table of your choice, making sure that you are using a color scheme appropriate to the type of data (quantitative v. qualitative). 

· Under the options for symbolizing the data, you can also select if and what attribute you want to label the data.  Since the Base Map already has city names, we do not need to label them.  But, go ahead and create a label for one of you Bike Crash data layers, as you see appropriate.

Editing your data.
· You can easily make changes to your map data at any point in the map-making process.  You may want to do this if you notice a typo or want to add (or delete) information to your info window.  Click on any data point or polygon on the map and you will notice that a pop-up window appears with all the data from the original table.
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· If you click on the pencil icon at the bottom of the info window, you can edit the data directly from this window.  

· Alternatively, you can make changes to your data from within the table view (you did this earlier by clicking on the Layer Options and selecting Open Data Table).  You can make changes to your data by click on any field in the table view.  The table and info window are linked, so any changes you make will be reflected in both places.  You can add rows to your table or you want to show more places, or delete an existing row.

· In the info window, you can also 

· change what column in your table is being used for the Title (Top of the info window)
· Add a photo or video

· Customize your info windows for the 2nd Bike Crash data layer you created in the previous section.  Feel free to delete rows if you want to limit what data is being displayed. 
· Now that you have a better understanding of your data and what you are representing on the map - click on the Map Title and write a description for your map.

Share & Embed your Map.
Once your map is all finished, you have options for how you can share this with others.  All maps are private by default, which means only you, as the creator of the map, can view or edit it.  You have the option of making the map public and embedding it on a website, sharing it with specific people, or allowing anyone with the link to the map to access it.

· Click on Share in the map menu (right next to Add Layer).  The screen (below) will appear.  Notice the 
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· Click on the ‘Change’ to see options for sharing.  
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· Change the settings to On- Anyone with the link.

1. Enter the link in your lab doc so that your instructor can view the map.

· You can choose to make the map Public on the web and further refine your share settings so that it is either viewable or editable by the public.  

· Sharing your map also allows you to collaborate or work with a group of people on the same map (just like other Google file types).   You can invite specific people to share the map and give them Edit access.  If you share your map with a Google Group, each member of the group will have access to your map.

· If you want to embed your map on a website you need to make it Public.  Once it is public, go to the Map menu and next to the Share button, you will see three vertical dots.  Click on the dots and go to Embed on my site.  Copy the HTML code and paste it into the source code of your website.  Note that you can customize the height and width of your map in the HTML code. 

Setting a default view for the map.
· It is possible to set the default view for the map so that whenever it is displayed it automatically goes to the view.  Position the map in your web browser the way that you want it to be viewed.  Go to the Map menu pulldown (three dots next to the Share button) and select Set Default View.

Accessing your Google Map.
· You Google My Map is saved to your Google Drive just like any other google document.

Export to KML. 
· Google My Maps can also be used to generate geospatial data and then export as a KML for use in other web mapping technologies.  Back in the first section, there is a description on how to create points, lines or polygons on the map.  If you want to create a data layer of information in Google My Maps, once you are finished, you can export as a KML.  To do this, go to the Map menu pulldown (three dots next to the Share button) and select Export to KML.

Part II | Google Earth.
Open Google Earth to get started. 

· Zoom into to Oregon, either by using the zoom controls, or by typing Oregon in the Search box. 

· For now, shut off everything in the Primary Database, except for Borders & Labels.  This will just make it easier to look at.

· Since we will taking advantage of the 3D features in Google Earth, let’s make sure that 3D Imagery is enabled.  Go to under Tools>Options and click on the 3D View tab.  Under Terrain, check (if it isn’t already) the box next to Use 3D Imagery.
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Adding placemarks and features.

· Before we get started with creating new data in Google Earth, let’s create a folder to add it to.  Go to Add>Folder and give it a name (i.e. Oregon Points of Interest).  This will appear in My Places. 

·  Across the top of the screen, you will see the main Google Earth Toolbar

[image: ]

· The push pin symbol on the left is the Add Placemark tool.  Click on the tool and it wil add a new placemark to you map.  You can pick up the push pin and move it wherever you would like on the map.  In the pop-up window that appears, you can also give the Placemark a name, description, and change the icon/color of the symbol representing that point.  

· You are going to create placemarks for several features found in Oregon.  If you have trouble finding a location, use the Search box to find it.  Add placements for the following locations (first read through the next few steps):

· Mount Hood
· Crater Lake national park
· OMSI
· Washington Park (Oregon Zoo)
· High Desert Museum
· Oregon Coast Aquarium
· Multnomah Falls
· Oregon Caves
· Lan Su Chinese Gardens

· For each placemark, add the name of the feature and a short description.  Change the symbol to something that is befitting to the feature and makes the map cohesive.

· Change the view of your placemark by changing the camera perspective.  This can be done for each placemark when creating the feature under the View tab or after the feature is created by right clicking on the feature in the Table of Contents and going to  Properties>View>Heading and Tilt.

· You can also add pictures to your placemarks – these pics need to be online (just like with all the other programs we have used).  You can do a Google Image search to find suitable pictures, just make sure that you do not use any pictures that are copyrighted.  

· Add pictures to at least 3 of your placemarks. To add pictures to a placemark’s balloon, right-click the placement and select properties.  Then click on the Add Image button.  In the image URL box, paste the URL to the image you want to use, then click OK.

· The HTML code for the picture will appear in the description box.  You may also add any text description in the box, then click the OK button at the bottom of the Edit Placemark box.

Creating a Viewshed.
It is now possible to create a viewshed directly in Google Earth.  A viewshed is an area that is visible from a specific point or location.  It includes the area around that point that are in the line-of-sight and excludes anything that are beyond the horizon or obstructed by terrain (and sometime other features like buildings or trees).

· In your ‘Places’, right-click on the Mt. Hood placemark and go to Show Viewshed.  You will probably get a warning that ‘Your placemark is too low’.  If you do, click on Adjust automatically.  Google Earth will calculate the viewshed from your Mt. hood point.

· When it does calculating, go to File>Save>Save image.  The view in GE changes – a legend appears, as does a north arrow, scale bar, and title/description.   Give your map a Title & Description and include all other map elements.  You can edit what is visible in your legend my clicking on it (same goes for the title & description).

· When you are finished, click on ‘Save Image’ and save the image as a .jpg.

1. Add the Viewshed map into your lab doc.

· Close the map image and exit the viewshed view.

Adding path & polygon features.
In addition to adding points on Google Earth, you can also create lines & polygons for other types of features.  

· Go to (or search for) Trillium Lake on Mt. Hood.  

· Select the Add polygon tool (on the Google Earth toolbar) and draw a polygon to trace the lake (as best as you can).  When you finish drawing it, name the polygon and adjust the transparency so that you can see the imagery below it.

· Next, use the Add Path tool to trace Trillium Lake Road from where it intersects with HWY 26 to Trillium lake.  Refer to the image below to get an idea of where it is (it is visible on the imagery in Google Earth).   Change the color of the line and make it a line thickness of 2 pts.   Name the path, Trillium Lake Road.
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· By default, paths are positioned or ‘clamped’ to ground level.  You can change the appearance and create interesting view by positioning the path above the ground.  Rick-click the path in My Places and click Properties.  Click on the Altitude tab.  Switch from ‘Clamped to ground’ to ‘Relative to ground’ and type in 300m (about 1000 ft).  Click on ‘Extend path to ground’.   Click OK on the properties window.  Your path should now appear above the surface.

Import GPS data.
Google Earth allows you to import GPS data in two ways – you can connect a GPS unit directly to your computer and import data from it or you can import data in a standard GPS file format such as .gpx.  Unfortunately, Google Earth does not import GPS files directly from the Trimble Juno – you must convert it first in Pathfinder Office into a .gpx, .kml or .shp.  

For this example, you will import data as a .gpx file (in Lab2data folder).  

· Go to File>open.  When the file browser opens, navigate to the Lab2Data folder that contains a GPS file, ponds.  IF YOU DON’T SEE IT – you need to change the file type to GPS.  Select the file and click Open.

· It should fly you over to Portland and show you Whitaker Ponds in NE Portland.


Create a tour. 
A unique feature of Google Earth is the ability to create tours, in which you can highlight points of interest.  If you have a microphone available, you can record a voice narration along with your tour.  You are going to create a tour highlighting the features you created in Oregon earlier in the lab.  

· Click the Record a Tour button on the toolbar.  The recording buttons will appear at the bottom left-hand side of the screen.
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· If you have a microphone and want to add some narrative, click on the microphone button to enable it.  

· Zoom back out to the state of Oregon as an initial extent.  Click on the button with the red dot to start the recording.  The timer should start counting the time while you are recording. 

· With the recording in progress, pan and zoom your map to the points of interest you created.  Or you could double-click the points in My Places , which will make the map zoom to each point.  Make sure to zoom to each point and give a brief narration, if possible. 

· You might have to practice the tour a couple of times before you are ready to save it and call it final.  

· To finish recording, click on the red button again.  When the playback slider appears, you can play back your recording.  

· On the playback slider, you can save your tour.   Be sure to save the tour!
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· Once you have the Tour in My Places, right-click on it and go to Save Place As and save the KMZ file to your flash drive or hard drive.

2. When you submit your lab doc, you will also attach the KMZ of your Tour. 

Creating & Adding Overlays. 
You can either create or find an image that you can overlay on top of the Google Earth imagery/data.  When you create an overlay, it integrates with the terrain or shape of the land beneath if the terrain layer is turned on.   One way to use this is to take a map that you created in ArcMap and overlay it in Google Earth to show the data over a more detailed base map, including terrain and any other features that may be available.

· The image you will bring in is a 1948 Topographic map of the Portland/Vancouver vicinity.  Go to this area in Google Earth (approximately).

· Click on the Add Image Overlay tool on the Google Earth Toolbar.   Go to Browse and search for the Vancouver, WA 1948 image.  Give the overlay a descriptive name.  

· In the google earth viewer, you can use the green markers to stretch and move the image a number of ways to get the image positioned correctly.  You will also need to change the transparency so that you can see what is below the image. 

· Take some time to accurately place the image.  When complete, click on the Terrain features under Layers and zoom around so you can see how that is incorporated into the image.  

· Turn on the Historical Imagery (clock icon on the Google Earth Toolbar).  Compare the 1948 topo map with the earliest imagery available.  

3. What are some major differences and/or similarities between the two images?  

Sharing & Saving your Google Earth project.
With Google Earth, you can typically save your content in KML or KMZ format (KMZ is just a zipped version of KML).  The convenient part about this, is you can send anyone else that KML or KMZ file and when they open it (assuming Google Earth is installed on their computer), it will automatically open in Google Earth.  

· Rick-click on your project folder and click Save Place As and save it to your flash drive or hard drive as a KMZ (and give it a name).

· MAKE SURE THAT ALL THE POINTS, LINES, POLYGONS, IMAGE, ETC. are in the folder you save so I can see your work!

4. When you submit your lab doc, attach the KMZ or the places you created for the lab. 
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